Skip to content

Commit 559fcbf

Browse files
committed
Add typerex
0 parents  commit 559fcbf

File tree

2 files changed

+38
-0
lines changed

2 files changed

+38
-0
lines changed

typerex/PKGBUILD

+31
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,31 @@
1+
# Maintainer: Thibaut Horel <thibaut dot horel at gmail dot com>
2+
3+
pkgname=typerex
4+
pkgver=1.0e
5+
pkgrel=1
6+
pkgdesc="An OCaml development environment."
7+
arch=('i686' 'x86_64')
8+
url="http://www.ocamlpro.com/typerex/"
9+
license=('GPL3')
10+
depends=('ocaml>=3.11.2' 'emacs>=23.2.1')
11+
optdepends=('emacs-auto-complete-git: for the auto-completion')
12+
install=typerex.install
13+
source=(http://www.ocamlpro.com/typerex/files/$pkgname-$pkgver.tar.bz2)
14+
md5sums=('768c53decdfa2925a9c15c790fdf0d1e')
15+
16+
build() {
17+
cd "$srcdir/$pkgname-$pkgver"
18+
./configure --bindir=/usr/bin \
19+
--with-lispdir=/usr/share/emacs/site-lisp \
20+
--disable-auto-complete
21+
make
22+
}
23+
24+
package() {
25+
cd "$srcdir/$pkgname-$pkgver"
26+
make BINDIR="$pkgdir/usr/bin" EMACSDIR="$pkgdir/usr/share/emacs/site-lisp" install
27+
install -m755 -d $pkgdir/usr/share/doc/$pkgname/
28+
cp -r docs/user-manual/* $pkgdir/usr/share/doc/$pkgname/
29+
install -m644 AUTHORS $pkgdir/usr/share/doc/$pkgname/
30+
install -m644 -D emacs.append $pkgdir/usr/share/$pkgname/config.el
31+
}

typerex/typerex.install

+7
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,7 @@
1+
post_install() {
2+
cat << EOF
3+
==> Don't forget to enable typerex in your .emacs.
4+
==> See the config file provided in /usr/share/typerex/
5+
cat /usr/share/typerex/config.el >> ~/.emacs
6+
EOF
7+
}

0 commit comments

Comments
 (0)