Skip to content

Commit e70a0a3

Browse files
committed
Link with system-provided MbedTLS library again
bibledit/cloud#944
1 parent 33dae95 commit e70a0a3

File tree

1 file changed

+8
-14
lines changed

1 file changed

+8
-14
lines changed

tarball-cloud.sh

+8-14
Original file line numberDiff line numberDiff line change
@@ -73,11 +73,6 @@ cd bibledit*
7373
if [ $? -ne 0 ]; then exit; fi
7474

7575

76-
# Copy the Debian packaging source to $TMPDEBIAN
77-
# cp -r $DEBIANSOURCE/debian .
78-
# The above was done for Ubuntu but is not correct for the Debian packaging.
79-
80-
8176
echo Change \"bibledit\" to \"bibledit-cloud\" in configuring code.
8277
sed -i.bak 's/share\/bibledit/share\/bibledit-cloud/g' configure.ac
8378
if [ $? -ne 0 ]; then exit; fi
@@ -142,20 +137,20 @@ if [ $? -ne 0 ]; then exit; fi
142137

143138
echo Link with the system-provided mbed TLS library.
144139
# It is important to use the system-provided mbedtls library because it is a security library.
145-
# This way, Debian updates to libmbedtls become available to Bibledit too.
146-
# With the embedded library, this is not the case.
140+
# This way, Debian updates to mbedtls become available to Bibledit too.
141+
# Were the library embedded, this would not be the case.
147142
# Fix for lintian error "embedded-library usr/bin/bibledit: mbedtls":
148143
# * Remove mbedtls from the list of sources to compile.
149144
# * Add -lmbedtls and friends to the linker flags.
150-
#sed -i.bak '/mbedtls\//d' Makefile.am
151-
#if [ $? -ne 0 ]; then exit; fi
152-
#sed -i.bak 's/# debian//g' Makefile.am
153-
#if [ $? -ne 0 ]; then exit; fi
154-
#rm *.bak
145+
sed -i.bak '/mbedtls\//d' Makefile.am
146+
if [ $? -ne 0 ]; then exit; fi
147+
sed -i.bak 's/# debian//g' Makefile.am
148+
if [ $? -ne 0 ]; then exit; fi
149+
rm *.bak
155150
# Also remove the embedded *.h files to be sure building does not reference them.
156151
# There had been a case that building used the embedded *.h files, leading to segmentation faults.
157152
# For cleanness, remove the whole mbedtls directory, so all traces of it are gone completely.
158-
#rm -rf mbedtls*
153+
rm -rf mbedtls*
159154

160155

161156
echo Link with the system-provided utf8proc library.
@@ -229,4 +224,3 @@ if [ $? -ne 0 ]; then exit; fi
229224

230225

231226
echo Ready creating bibledit-cloud tarball for Debian.
232-

0 commit comments

Comments
 (0)