Skip to content
This repository was archived by the owner on Feb 6, 2025. It is now read-only.

Commit f63525d

Browse files
committed
move ruff to dev dependency and update readme
1 parent 59a8c0c commit f63525d

File tree

5 files changed

+33
-27
lines changed

5 files changed

+33
-27
lines changed

README.md

+7-2
Original file line numberDiff line numberDiff line change
@@ -36,7 +36,12 @@ This tests adds some customization to the output of unit tests, and has a functi
3636
```
3737
3838
## Building a package
39-
From the package folder containing `pyproject.toml`, run `python -m build`. The generated `.whl` file will be in the `dist` folder.
39+
From the package folder containing `pyproject.toml`, run `pipenv run python -m build`. The generated `.whl` file will be in the `dist` folder.
4040
4141
## Run tests
42-
From the folder containing code and tests, run `python -m unittest`. This will look for tests in all files that start with `test`.
42+
From the folder containing code and tests, run `pipenv run python -m unittest`. This will look for tests in all files that start with `test`.
43+
44+
# Linting
45+
We use [ruff](https://docs.astral.sh/ruff/installation/) for linting. It is a dev dependency of all of our packages. You can install it on
46+
your editor of choice for inline suggestions (for example, [VS Code](https://marketplace.visualstudio.com/items?itemName=charliermarsh.ruff)),
47+
and run it on the command line via `ruff check`. It also runs as part of the PR check process.

packages/pythonlab_setup/Pipfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -7,9 +7,9 @@ name = "pypi"
77
build = "*"
88
requests = "*"
99
matplotlib = "*"
10-
ruff = "*"
1110

1211
[dev-packages]
12+
ruff = "*"
1313

1414
[requires]
1515
python_version = "3.12"

packages/pythonlab_setup/Pipfile.lock

+20-19
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

packages/unittest_runner/Pipfile

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,9 +4,9 @@ verify_ssl = true
44
name = "pypi"
55

66
[packages]
7-
ruff = "*"
87

98
[dev-packages]
9+
ruff = "*"
1010

1111
[requires]
1212
python_version = "3.12"

packages/unittest_runner/Pipfile.lock

+4-4
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

0 commit comments

Comments
 (0)