Skip to content

Commit 6ebb895

Browse files
committed
mingw-w64-curl: update to 8.11.1
drop the two backported regression fixes for ~/.netrc parsing as they're part of curl 8.11.1. Backport another regression fix that restores the fallback to ~/_netrc on Windows. Signed-off-by: Matthias Aßhauer <[email protected]>
1 parent 4f83a26 commit 6ebb895

File tree

2 files changed

+32
-13
lines changed

2 files changed

+32
-13
lines changed
+26
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,26 @@
1+
From 0439499170b4e5ad4d4b4679ad284b4aa4df16f1 Mon Sep 17 00:00:00 2001
2+
From: Kevin Sun <[email protected]>
3+
Date: Thu, 12 Dec 2024 17:35:12 -0800
4+
Subject: [PATCH] netrc: restore _netrc fallback logic
5+
6+
Regression from 05977f4f75fd08837a877, shipped in 8.11.0
7+
8+
Fixes #15734
9+
Closes #15735
10+
---
11+
lib/netrc.c | 2 +-
12+
1 file changed, 1 insertion(+), 1 deletion(-)
13+
14+
diff --git a/lib/netrc.c b/lib/netrc.c
15+
index d5ee3c0fd564a8..056ea96a7c8010 100644
16+
--- a/lib/netrc.c
17+
+++ b/lib/netrc.c
18+
@@ -390,7 +390,7 @@ int Curl_parsenetrc(struct store_netrc *store, const char *host,
19+
retcode = parsenetrc(store, host, loginp, passwordp, filealloc);
20+
free(filealloc);
21+
#ifdef _WIN32
22+
- if(retcode == NETRC_FILE_MISSING) {
23+
+ if((retcode == NETRC_FILE_MISSING) || (retcode == NETRC_FAILED)) {
24+
/* fallback to the old-style "_netrc" file */
25+
filealloc = aprintf("%s%s_netrc", home, DIR_CHAR);
26+
if(!filealloc) {

mingw-w64-curl/PKGBUILD

+6-13
Original file line numberDiff line numberDiff line change
@@ -5,8 +5,8 @@ pkgbase=mingw-w64-${_realname}
55
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}"
66
"${MINGW_PACKAGE_PREFIX}-${_realname}-gnutls"
77
"${MINGW_PACKAGE_PREFIX}-${_realname}-winssl")
8-
pkgver=8.11.0
9-
pkgrel=2
8+
pkgver=8.11.1
9+
pkgrel=1
1010
pkgdesc="Command line tool and library for transferring data with URLs (mingw-w64)"
1111
arch=('any')
1212
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64' 'clang32' 'clangarm64')
@@ -36,16 +36,14 @@ source=("https://github.com/curl/curl/releases/download/${_realname}-${pkgver//.
3636
"pathtools.h"
3737
"0001-Make-cURL-relocatable.patch"
3838
"0002-Hack-make-relocation-work-inside-libexec-git-core-an.patch"
39-
"netrc-regression-1.patch::https://github.com/curl/curl/commit/f5c616930b5cf148b1b2632da4f5963ff48bdf88.patch"
40-
"netrc-regression-2.patch::https://github.com/curl/curl/commit/0cdde0fdfbeb8c35420f6d03fa4b77ed73497694.patch")
41-
sha256sums=('c95d5a1368803729345a632ce42cceeefd5f09c3b4d9582f858f6779f4b8b254'
39+
"0003-netrc-regression.patch")
40+
sha256sums=('e9773ad1dfa21aedbfe8e1ef24c9478fa780b1b3d4f763c98dd04629b5e43485'
4241
'SKIP'
4342
'08209cbf1633fa92eae7e5d28f95f8df9d6184cc20fa878c99aec4709bb257fd'
4443
'965d3921ec4fdeec94a2718bc2c85ce5e1a00ea0e499330a554074a7ae15dfc6'
4544
'd34c9474a0b54d36497e58b4792699ef37cc8b043a4cd5daf287e1e33f660207'
4645
'418b5619b924d17ac71066323b5540d86d4e8055cabab925ece185770e9d1906'
47-
'708429a4e0b387dc9addc1f9166e07e5db22da42221887ddab9533c9e2bd1ca8'
48-
'd817dd3746476bc513edd24a4f9a32674c3d5a04484bf80d894c1d2add67e8e2')
46+
'19af1ecce5f14e6bb5e58f2dce07c94c1c8cfc23772a066e5f89f92e0dfd11c2')
4947
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
5048

5149
if test -z "$WITHOUT_ALTERNATES"
@@ -90,18 +88,13 @@ prepare() {
9088
cmp "${startdir}/../mingw-w64-pathtools/pathtools.h" "${srcdir}/pathtools.h"
9189
} || exit 1
9290

93-
test ! -f "${srcdir}/netrc-regression-1.patch" ||
94-
rm -f ${_realname}-${pkgver}/tests/data/test2309 \
95-
${_realname}-${pkgver}/tests/libtest/lib2309.c
96-
9791
cd "${srcdir}/${_realname}-${pkgver}"
9892
cp -fHv "${srcdir}"/pathtools.[ch] lib/
9993

10094
apply_patch_with_msg \
10195
0001-Make-cURL-relocatable.patch \
10296
0002-Hack-make-relocation-work-inside-libexec-git-core-an.patch \
103-
netrc-regression-1.patch \
104-
netrc-regression-2.patch
97+
0003-netrc-regression.patch
10598

10699
autoreconf -vfi
107100
}

0 commit comments

Comments
 (0)