Skip to content

Commit

Permalink
fs/ubifs: spin-off ubi to be its own filesystem
Browse files Browse the repository at this point in the history
Currently, the ubifs-in-ubi-image ("UBI image" thereafter) filesystem
is half an option of the ubifs filesystem, half a filesystem on its
own: the config options are options of the ubifs filesystem, but the
.mk code is in a separate .mk and registers a real filesystem.

Make it a full filesystem on its own, in its own directory tree.

Signed-off-by: "Yann E. MORIN" <[email protected]>
Cc: Thomas Petazzoni <[email protected]>
Signed-off-by: Thomas Petazzoni <[email protected]>
  • Loading branch information
yann-morin-1998 authored and tpetazzoni committed Jan 3, 2018
1 parent 1897a56 commit 9fc2166
Show file tree
Hide file tree
Showing 5 changed files with 53 additions and 52 deletions.
1 change: 1 addition & 0 deletions fs/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@ source "fs/jffs2/Config.in"
source "fs/romfs/Config.in"
source "fs/squashfs/Config.in"
source "fs/tar/Config.in"
source "fs/ubi/Config.in"
source "fs/ubifs/Config.in"
source "fs/yaffs2/Config.in"

Expand Down
51 changes: 51 additions & 0 deletions fs/ubi/Config.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
config BR2_TARGET_ROOTFS_UBI
bool "ubi image containing an ubifs root filesystem"
select BR2_TARGET_ROOTFS_UBIFS
help
Build an ubi image from the ubifs one (with ubinize).

if BR2_TARGET_ROOTFS_UBI

config BR2_TARGET_ROOTFS_UBI_PEBSIZE
hex "physical eraseblock size"
default 0x20000
help
Tells ubinize the physical eraseblock (PEB) size of the
flash chip the ubi image is created for. The value provided
here is passed to the -p/--peb-size option of ubinize.

config BR2_TARGET_ROOTFS_UBI_SUBSIZE
int "sub-page size"
default 512
help
Tells ubinize that the flash supports sub-pages and the sub-page
size. Use 0 if sub-pages are not supported on flash chip.
The value provided here is passed to the -s/--sub-page-size
option of ubinize.

config BR2_TARGET_ROOTFS_UBI_USE_CUSTOM_CONFIG
bool "Use custom config file"
help
Select this option to use a custom ubinize configuration file,
rather than the default configuration used by Buildroot (which
defines a single dynamic volume marked as auto-resize). Passing
a custom ubinize configuration file allows you to create several
volumes, specify volume types, etc.

As a convenience, buildroot replaces the string
"BR2_ROOTFS_UBIFS_PATH" with the path to the built ubifs file.
So the volume defined for the root filesystem can specify the
image path as: image=BR2_ROOTFS_UBIFS_PATH

config BR2_TARGET_ROOTFS_UBI_CUSTOM_CONFIG_FILE
string "Configuration file path"
depends on BR2_TARGET_ROOTFS_UBI_USE_CUSTOM_CONFIG
help
Path to the ubinize configuration file.

config BR2_TARGET_ROOTFS_UBI_OPTS
string "Additional ubinize options"
help
Any additional ubinize options you may want to include.

endif # BR2_TARGET_ROOTFS_UBI
2 changes: 1 addition & 1 deletion fs/ubifs/ubi.mk → fs/ubi/ubi.mk
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ ROOTFS_UBI_DEPENDENCIES = rootfs-ubifs
ifeq ($(BR2_TARGET_ROOTFS_UBI_USE_CUSTOM_CONFIG),y)
UBINIZE_CONFIG_FILE_PATH = $(call qstrip,$(BR2_TARGET_ROOTFS_UBI_CUSTOM_CONFIG_FILE))
else
UBINIZE_CONFIG_FILE_PATH = fs/ubifs/ubinize.cfg
UBINIZE_CONFIG_FILE_PATH = fs/ubi/ubinize.cfg
endif

# don't use sed -i as it misbehaves on systems with SELinux enabled when this is
Expand Down
File renamed without changes.
51 changes: 0 additions & 51 deletions fs/ubifs/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -95,55 +95,4 @@ config BR2_TARGET_ROOTFS_UBIFS_OPTS
help
Any additional mkfs.ubifs options you may want to include.

config BR2_TARGET_ROOTFS_UBI
bool "Embed into an UBI image"
help
Build an ubi image from the ubifs one (with ubinize).

if BR2_TARGET_ROOTFS_UBI

config BR2_TARGET_ROOTFS_UBI_PEBSIZE
hex "physical eraseblock size"
default 0x20000
help
Tells ubinize the physical eraseblock (PEB) size of the
flash chip the ubi image is created for. The value provided
here is passed to the -p/--peb-size option of ubinize.

config BR2_TARGET_ROOTFS_UBI_SUBSIZE
int "sub-page size"
default 512
help
Tells ubinize that the flash supports sub-pages and the sub-page
size. Use 0 if sub-pages are not supported on flash chip.
The value provided here is passed to the -s/--sub-page-size
option of ubinize.

config BR2_TARGET_ROOTFS_UBI_USE_CUSTOM_CONFIG
bool "Use custom config file"
help
Select this option to use a custom ubinize configuration file,
rather than the default configuration used by Buildroot (which
defines a single dynamic volume marked as auto-resize). Passing
a custom ubinize configuration file allows you to create several
volumes, specify volume types, etc.

As a convenience, buildroot replaces the string
"BR2_ROOTFS_UBIFS_PATH" with the path to the built ubifs file.
So the volume defined for the root filesystem can specify the
image path as: image=BR2_ROOTFS_UBIFS_PATH

config BR2_TARGET_ROOTFS_UBI_CUSTOM_CONFIG_FILE
string "Configuration file path"
depends on BR2_TARGET_ROOTFS_UBI_USE_CUSTOM_CONFIG
help
Path to the ubinize configuration file.

config BR2_TARGET_ROOTFS_UBI_OPTS
string "Additional ubinize options"
help
Any additional ubinize options you may want to include.

endif # BR2_TARGET_ROOTFS_UBI

endif # BR2_TARGET_ROOTFS_UBIFS

0 comments on commit 9fc2166

Please sign in to comment.