forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
luajit: update Makefile to build from git
LuaJIT has a "rolling release" where we should follow git HEAD[1]. I believe that the currently tagged version is tracking code from 2017. This PR updates the Makefile to latest HEAD. Closes openwrt#25299 1. https://luajit.org/download.html Build system: x86/64 Build-tested: x86/64/AMD Cezanne Run-tested: x86/64/AMD Cezanne Signed-off-by: John Audia <[email protected]>
- Loading branch information
Showing
8 changed files
with
18 additions
and
3,601 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,14 +1,14 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=luajit | ||
PKG_VERSION:=2.1.0 | ||
PKG_REAL_VERSION:=$(PKG_VERSION)-beta3 | ||
PKG_RELEASE:=8 | ||
PKG_SOURCE_DATE:=2024-11-13 | ||
PKG_VERSION:=2.1.$(subst -,,$(PKG_SOURCE_DATE)) | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=LuaJIT-$(PKG_REAL_VERSION).tar.gz | ||
PKG_SOURCE_URL:=https://luajit.org/download | ||
PKG_HASH:=1ad2e34b111c802f9d0cdf019e986909123237a28c746b21295b63c9e785d9c3 | ||
PKG_BUILD_DIR:=$(BUILD_DIR)/LuaJIT-$(PKG_REAL_VERSION) | ||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://github.com/LuaJIT/LuaJIT.git | ||
PKG_SOURCE_VERSION:=69bbf3c1b01de8239444b0c430a89fa868978fea | ||
PKG_MIRROR_HASH:=617aafabe07715e80019f0dc3b9bc28c77e95f5c390d2015ef386c4c58da17a0 | ||
|
||
PKG_MAINTAINER:=Morteza Milani <[email protected]> | ||
PKG_LICENSE:=MIT | ||
|
@@ -70,14 +70,12 @@ define Build/InstallDev | |
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*so* $(1)/usr/lib/ | ||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/luajit.pc $(1)/usr/lib/pkgconfig/ | ||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/luajit-$(PKG_REAL_VERSION) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) | ||
endef | ||
|
||
define Package/luajit/install | ||
$(INSTALL_DIR) $(1)/usr/lib/ | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/ | ||
$(INSTALL_DIR) $(1)/usr/bin | ||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/luajit-$(PKG_REAL_VERSION) $(1)/usr/bin/$(PKG_NAME) | ||
endef | ||
|
||
define Host/Compile | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
26 changes: 0 additions & 26 deletions
26
lang/luajit/patches/030_fix_posix_install_with_missing_or_incompatible_ldconfig.patch
This file was deleted.
Oops, something went wrong.
Oops, something went wrong.