Skip to content

Commit

Permalink
addpatch: openxr, ver=1.0.28-1 (#140)
Browse files Browse the repository at this point in the history
* Temporary fix from
[OpenXR-SDK-Source#479](KhronosGroup/OpenXR-SDK-Source#479)

Signed-off-by: Zhou Qiankang <[email protected]>
  • Loading branch information
wszqkzqk authored Oct 8, 2024
1 parent 63b217f commit 070c6e3
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
84 changes: 84 additions & 0 deletions openxr/add-loong64-support.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
From 22b320b31cf34495d37de8768cecd27d5e4da676 Mon Sep 17 00:00:00 2001
From: qiangxuhui <[email protected]>
Date: Tue, 4 Jun 2024 03:29:41 +0000
Subject: [PATCH 1/3] Add support for loongarch64

Fix build on linux/loongarch64.
---
src/common/platform_utils.hpp | 2 ++
1 file changed, 2 insertions(+)

diff --git a/src/common/platform_utils.hpp b/src/common/platform_utils.hpp
index d047c17d..7fcba27e 100644
--- a/src/common/platform_utils.hpp
+++ b/src/common/platform_utils.hpp
@@ -71,6 +71,8 @@
#define XR_ARCH_ABI "riscv64"
#elif defined(__sparc__) && defined(__arch64__)
#define XR_ARCH_ABI "sparc64"
+#elif defined(__loongarch64)
+#define XR_ARCH_ABI "loongarch64"
#else
#error "No architecture string known!"
#endif

From e6f1df21f156b78ecb6b578afa56449dcf72dd09 Mon Sep 17 00:00:00 2001
From: qiangxuhui <[email protected]>
Date: Wed, 5 Jun 2024 01:47:08 +0000
Subject: [PATCH 2/3] Add loong64's info to loader doc

---
specification/loader/runtime.adoc | 5 +++++
src/common/platform_utils.hpp | 2 +-
2 files changed, 6 insertions(+), 1 deletion(-)

diff --git a/specification/loader/runtime.adoc b/specification/loader/runtime.adoc
index 930adc66..b907a658 100644
--- a/specification/loader/runtime.adoc
+++ b/specification/loader/runtime.adoc
@@ -379,6 +379,11 @@ architectures and ABIs is used.
| `sparc64`
| 64-bit SPARC architecture

+|`loong64`
+ |
+ | `loong64`
+ | 64-bit LoongArch architecture, little endian
+
|===

[[android-arm32-note]]
diff --git a/src/common/platform_utils.hpp b/src/common/platform_utils.hpp
index 7fcba27e..e080cf90 100644
--- a/src/common/platform_utils.hpp
+++ b/src/common/platform_utils.hpp
@@ -72,7 +72,7 @@
#elif defined(__sparc__) && defined(__arch64__)
#define XR_ARCH_ABI "sparc64"
#elif defined(__loongarch64)
-#define XR_ARCH_ABI "loongarch64"
+#define XR_ARCH_ABI "loong64"
#else
#error "No architecture string known!"
#endif

From 4fc37fa22fb42fd0d4cb7465b61383184b00a207 Mon Sep 17 00:00:00 2001
From: qiangxuhui <[email protected]>
Date: Wed, 5 Jun 2024 07:03:28 +0000
Subject: [PATCH 3/3] Changelog fragment

---
changes/sdk/pr.479.gh.OpenXR-SDK-Source.md | 4 ++++
1 file changed, 4 insertions(+)
create mode 100644 changes/sdk/pr.479.gh.OpenXR-SDK-Source.md

diff --git a/changes/sdk/pr.479.gh.OpenXR-SDK-Source.md b/changes/sdk/pr.479.gh.OpenXR-SDK-Source.md
new file mode 100644
index 00000000..123559d5
--- /dev/null
+++ b/changes/sdk/pr.479.gh.OpenXR-SDK-Source.md
@@ -0,0 +1,4 @@
+---
+- pr.479.gh.OpenXR-SDK-Source
+---
+Loader: Fix build error on loong64, and add loong64 in the architecture table in the loader documentation.
15 changes: 15 additions & 0 deletions openxr/loong.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
diff --git a/PKGBUILD b/PKGBUILD
index 5411038..dafbc15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,3 +33,10 @@ package() {

DESTDIR="$pkgdir" ninja -C build install
}
+
+prepare() {
+ patch -d OpenXR-SDK-Source-release-${pkgver} -p1 -i "${srcdir}/add-loong64-support.patch"
+}
+
+source+=("add-loong64-support.patch")
+sha512sums+=('fc739951a179f2af9598eef6988f95f799da454593d05b7c7827a43be18103f2ebf4d05bb738b09588a410b44301d3bfc42679e0514452d671e5455f3a26b7da')

0 comments on commit 070c6e3

Please sign in to comment.